This project is read-only.

Installation in VS 2008 does not work

Jan 14, 2008 at 3:56 PM
I executed the install for ORCAS (VS 2008)
(at the end of the install, it download or opens the 2005 zip for some reason)
It does not show up in the Add-in manager.
I copied the Add-in into a folder recognized by macros to no avail.

I find this utility really useful, I would hate to loose it in team explorer 2008
Any ideas on resolving the issue?

Thanks
Feb 4, 2008 at 4:10 PM
As a work around you simply have to copy the addin folder from "Visual Studio Codename Orcas" to "Visual Studio 2008" for the add-in to work in your Team Explorer 2008

ex:
C:\Documents and Settings\<user.name>\My Documents\Visual Studio 2008\Addins
Feb 20, 2008 at 3:04 PM
I performed the install as suggested, copied the addins folder to my My Documents\Visual Studio 2008\Addins folder...

I see the add-in listed in my Add-Ins via AddIn manger. Its checked for Startup...

yet, I do not see the option when I try to Customize any existing toolbars, and there is no "Work Item Tracking - Search Work Items toolbar" listed in VS. It also does not show in the Team Menu.

Any Ideas?

Thanks,
Nate
Mar 24, 2008 at 4:48 PM
VS needs to be closed and start again to load newly added add-in.

Apr 21, 2008 at 9:47 PM
I am unable to get the toolbars, etc to appear for vs2008. vs2005 works fine. Yes I restarted vs2008. I see it in the addin manager for both vs2005 and vs2008.

Where is the source code for vs2008 - I would debug it myself and find the issues.
Oct 6, 2008 at 7:44 PM
I had another Addin, and I searched for where it was in the file system.
It was in All Users\Application Data\Microsoft\MSEnvShared\AddIns

I copied the files created in this install from the place it was put to that directory and then I got it to work.
If you cannot find the files, search for *.addin

Hope this helps someone.

/Tomas
Oct 29, 2008 at 5:22 PM
I think I have a similar problem. I've installed the V2.1.0 for VS 2008 SP1, can see it in the addin manager but cannot find the toolbar or any additional menu item.
Has anyone a hint for a solution?
Jun 3, 2009 at 10:42 PM

I also cannot load Search Work Items properly.  If I launch VS.NET with the /log switch, here are the Search Work Item related events:

  <entry>

    <record>44</record>

    <time>2009/06/03 21:07:44.048</time>

    <type>Information</type>

    <source>Microsoft Visual Studio</source>

    <description>Loading .NET AddIn: SearchWorkItems.Connect</description>

  </entry>

  <entry>
    <record>52</record>
    <time>2009/06/03 21:07:44.376</time>
    <type>Error</type>
    <source>Microsoft Visual Studio</source>
    <description>Calling OnConnection for Addin: SearchWorkItems.Connect</description>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo>A Command with that name already exists.</errorinfo>
  </entry>
  <entry>
    <record>53</record>
    <time>2009/06/03 21:07:44.376</time>
    <type>Information</type>
    <source>Microsoft Visual Studio</source>
    <description>Unloading AddIn and calling OnDisConnection: SearchWorkItems.Connect</description>
  </entry>
  <entry>
    <record>63</record>
    <time>2009/06/03 21:07:46.079</time>
    <type>Information</type>
    <source>Microsoft Visual Studio</source>
    <description>Loading .NET AddIn: SearchWorkItems.Connect</description>
  </entry>
  <entry>
    <record>64</record>
    <time>2009/06/03 21:07:46.095</time>
    <type>Information</type>
    <source>Microsoft Visual Studio</source>
    <description>Calling OnConnection for Addin: SearchWorkItems.Connect</description>
  </entry>

Not sure if the error is significant or not.
Love to find out if anyone else has figured out this issue.